1041. Be Unique (20)-PAT

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
推荐指数:※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1041
数的范围不大,直接映射关系
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
const int N=10010;

int main()
{
	int n,i;
	int *val=new int [N];
	memset(val,0,N*sizeof(int));
	scanf("%d",&n);
	int *num=new int[n]; 
	for(i=0;i<n;i++){
		scanf("%d",&num[i]);
		val[num[i]]++;
	}
	for(i=0;i<n;i++){
		if(val[num[i]]==1){
			printf("%d\n",num[i]);
			break;
		}
	}
	if(i==n)
		printf("None\n");
	return 0;

}


你可能感兴趣的:(1041. Be Unique (20)-PAT)