hdoj 1085 Holding Bin-Laden Captive!【基础母函数】

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17382    Accepted Submission(s): 7797


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”

hdoj 1085 Holding Bin-Laden Captive!【基础母函数】_第1张图片

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
   
   
   
   
1 1 3 0 0 0
 

Sample Output
   
   
   
   
4
 

队友问我这个题,发现自己还没A。。。1个多月没做母函数了,但没想到纯手写 写的的挺顺。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 8000+10
using namespace std;
int c1[MAXN], c2[MAXN];
int main()
{
    int a[4], val[4];
    while(scanf("%d%d%d", &a[1], &a[2], &a[3]), a[1] || a[2] || a[3])
    {
        memset(c1, 0, sizeof(c1));
        memset(c2, 0, sizeof(c2));
        int sum = a[1] + a[2] * 2 + a[3] * 5 + 1;//忘加一 WA了一次
        for(int i = 0; i <= a[1]; i++)
            c1[i] = 1;
        val[2] = 2, val[3] = 5;//附加对应系数
        for(int i = 2; i <= 3; i++)
        {
            for(int j = 0; j <= sum; j++)
            {
                for(int k = 0, used = 0; k + j <= sum && used <= a[i]; k += val[i], used++)
                c2[k+j] += c1[j];
            }
            for(int j = 0; j <= sum; j++)//更新
            {
                c1[j] = c2[j];
                c2[j] = 0;
            }
        }         
        for(int i = 0; i <= sum; i++)
        {
            if(c1[i] == 0)
            {
                printf("%d\n", i);
                break;
            }
        }
    }
    return 0;
}


你可能感兴趣的:(hdoj 1085 Holding Bin-Laden Captive!【基础母函数】)