hdu 1324 Pseudo-Random Numbers

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1324

题目描述:

Pseudo-Random Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 575    Accepted Submission(s): 256


Problem Description
Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation. 
A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( Z x L + I ) mod M, where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows: 

hdu 1324 Pseudo-Random Numbers_第1张图片

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M. 

In this problem you will be given sets of values for Z, I, M, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed! 
 

Input
Each input line will contain four integer values, in order, for Z, I, M, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M. 
 

Output
For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated. 
 

Sample Input
   
   
   
   
7 5 12 4 5173 3849 3279 1511 9111 5309 6000 1234 1079 2136 9999 1237 0 0 0 0
 

Sample Output
   
   
   
   
Case 1: 6 Case 2: 546 Case 3: 500 Case 4: 220


题意:

判断伪随机序列的循环长度

题解:

直接递推,然后判断循环和获取长度。注意递推过程中用了两个数组来记录是否已经访问过和首次访问的索引值。第一个数组用于判断是否产生循环,而第二个数组则是用于获取循环长度。

代码:

#include<stdio.h>
#include<string.h>
int Z,I,M,L;
int cases=0;
bool visited[10000]={false};
int inds[10000]={0};
int main()
{
    while(scanf("%d%d%d%d",&Z,&I,&M,&L)!=EOF&&(Z+I+M+L)>0)
    {
        printf("Case %d: ",++cases);
        memset(visited,false,sizeof(visited));
        int ind=1;
        visited[L]=true;
        inds[L]=ind++;
        while(true)
        {
            L=(Z*L+I)%M;
            if(visited[L]) break;
            visited[L]=true;
            inds[L]=ind++;
        }
        printf("%d\n",ind-inds[L]);
    }
    return(0);
}






你可能感兴趣的:(ACM,伪随机数)