joj 2223: A Bug's Life (ws版的并查集)

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
10s 8192K 544 115 Standard

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input Specification

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output Specification


The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

//居然删掉没用的头文件和命名空间也能缩时
#include <stdio.h>//disjoint-set forest
const int maxn=2010;
int I=1;
int p[maxn],rank[maxn],opp[maxn];
void make (int x)
{
    p[x]=x;
    rank[x]=0;
    opp[x]=x;
}
//----------
int find (int x)//查找父节点
{
    if(p[x]!=x)
     p[x]=find(p[x]);
    return p[x];
}
//----------
void merge (int a,int b)//按秩合并
{
    int x=find(a);
    int y=find(b);
    if(rank[x]>rank[y])
     p[y]=x;
    else p[x]=y;
    if(rank[x]==rank[y])
    rank[y]++;
}
int bn,in,i,a,b;
int n;
int main ()
{
    scanf("%d",&n);
    while(n--)
    {
        bool Isfound = 0;
        scanf("%d%d",&bn,&in);
        for ( i=1 ; i<=bn ; i++ )
         make(i);
        for ( i=1 ; i<=in ; i++)
        {
            scanf("%d%d",&a,&b);
            int fa=find(a);
            int fb=find(b);
            if(fa==fb)
             Isfound=1;
            if(opp[a]!=a)//如果opp中记录的不是自己,则将b与opp[a]合并
             merge(b,opp[a]);
            else opp[a]=b;
            if(opp[b]!=b)
             merge(a,opp[b]);
            else opp[b]=a;
        }
        if(Isfound)
         printf("Scenario #%d:/nSuspicious bugs found!/n/n",I++);
        else
         printf("Scenario #%d:/nNo suspicious bugs found!/n/n",I++);
    }
 return 0;
}

你可能感兴趣的:(input,each,merge,bugs,behavior,Numbers)