Stars
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 23703 |
|
Accepted: 10339 |
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source
Ural Collegiate Programming Contest 1999
这题如果就按一般思路每次向前全部比较的话会TLE,这里用树状数组可以大大减少时间。
树状数组,额,我也刚刚学,推荐个地址给大家 http://blog.csdn.net/swm8023/article/details/6540255
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[15010],c[32002];
int n,x,y;
int lowbit(int x)
{
return x&(-x);
}
int sum(int i)
{
int s=0;
while(i>0)
{
s+=c[i];
i-=lowbit(i);
}
return s;
}
void ad(int i)
{
while(i<=32001)
{
c[i]++;
i+=lowbit(i);
}
}
int main()
{
memset(a,0,sizeof(a));
memset(c,0,sizeof(c));
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
a[sum(++x)]++;
ad(x);
}
for(int i=0;i<n;i++)cout<<a[i]<<endl;
return 0;
}