杭电 2817 二分

        题意很简单,就是一个数列或者是等差数列或者是等比数列,如果是等比数列,用二分法就可以了。题目:

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1001    Accepted Submission(s): 328


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
   
   
   
   
2 1 2 3 5 1 2 4 5
 

Sample Output
   
   
   
   
5 16
 

ac代码:

#include <iostream>
#include <cstdio>
using namespace std;
_int64 a,b,c,k;
#define M 200907
_int64 binary_search(_int64 x,_int64 y){
  if(y==1)
	  return x;
  _int64 ans=binary_search(x,y/2);
  return ((ans*ans%M)*((y%2?x:1)%M))%M;
}
void fun(){
  _int64 d=b/a;
  _int64 xx=binary_search(d,k-1);
  _int64 yy=((a%M)*(xx%M))%M;
  printf("%I64d\n",yy);
}
int main(){
  //freopen("1.txt","r",stdin);
  int numcase;
  scanf("%d",&numcase);
  while(numcase--){
	scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);
	int flag=0;
	if(c-b==b-a)flag=1;
	if(flag==1){
	  _int64 d=b-a;
	  _int64 x=(((k-1)*d)%M+a%M)%M;
	  printf("%I64d\n",x%M);
	}
	else{
	  fun();  
	}
  }
  return 0;
}


你可能感兴趣的:(Integer,search,each,fun,output,Numbers)