1058. A+B in Hogwarts (20)- PAT

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
推荐指数:※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1058
不要想的太复杂
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
	long a[3];
	long b[3];
	scanf("%ld.%ld.%ld",&a[0],&a[1],&a[2]);
	scanf("%ld.%ld.%ld",&b[0],&b[1],&b[2]);
	int tmp;
	tmp=a[2]+b[2];
	if(tmp>=29){
		a[2]=tmp-29;
		a[1]++;
	}
	else
		a[2]=tmp;
	tmp=a[1]+b[1];
	if(tmp>=17){
		a[1]=tmp-17;
		a[0]++;
	}
	else
		a[1]=tmp;
	a[0]+=b[0];
	int i=0;
	cout<<a[0]<<"."<<a[1]<<"."<<a[2]<<endl;
	return 0;
}


你可能感兴趣的:(1058. A+B in Hogwarts (20)- PAT)