1051. Pop Sequence (25)-PAT

1051. Pop Sequence (25)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
推荐指数:※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1051
使用一个栈,模拟pop和push的过程。
#include<stdio.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
bool check_stack(int m,int n,int *pops)
{
	int top,pop_now,curr;
	int *st=new int [m+1];
	top=0,pop_now=1,curr=0;//top: stack top now;pop_now:now to handle;curr:first wait to push
	while(pop_now<=n&&curr<=n){
		if(0==top||st[top]!=pops[pop_now]){
			if(top+1>m)
				return false;
			else
				st[++top]=++curr;
		}
		else//if equal, emulate operate of pop
		{
			top--;
			pop_now++;
		}
	}
	if(top>0)
		return false;
	return true;
}
int main()
{
	int m,n,k;
	scanf("%d%d%d",&m,&n,&k);
	int i,j;
	for(i=0;i<k;i++)//check times
	{
		int *pops=new int [n+1];
		for(j=1;j<=n;j++)//input sequence
			scanf("%d",&pops[j]);

		if(check_stack(m,n,pops)==true)
			printf("YES\n");
		else
			printf("NO\n");

	}
	return 0;
}


你可能感兴趣的:(1051. Pop Sequence (25)-PAT)