题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5500
Reorder the Books
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 353 Accepted Submission(s): 241
Problem Description
dxy has a collection of a series of books called "The Stories of SDOI",There are
n(n≤19)
books in this series.Every book has a number from
1
to
n
.
dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.
One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books.
Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.
Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.
Input
There are several testcases.
There is an positive integer
T(T≤30)
in the first line standing for the number of testcases.
For each testcase, there is an positive integer
n
in the first line standing for the number of books in this series.
Followed
n
positive integers separated by space standing for the order of the disordered books,the
ith
integer stands for the
ith
book's number(from top to bottom).
Hint:
For the first testcase:Moving in the order of
book3,book2,book1
,
(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4)
,and this is the best way to reorder the books.
For the second testcase:It's already ordered so there is no operation needed.
Output
For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.
Sample Input
Sample Output
Source
BestCoder Round #59 (div.1)
Recommend
hujie | We have carefully selected several similar problems for you: 5503 5502 5501 5499 5498
题目大意:给出一列数字,每次选出一个数字移动到最前面,输出的是最少需要移动几次使得原本序列变成一个增序!
解题思路:原本想着用模拟的,但是模拟到一半发现很麻烦,并且奇迹的发现它是有规律的~~~~
规律是这样的:先找到最大的,判断它是否在最后一位,如果不在,那么就直接输出n-1,如果在的话,就去不断向前寻找,找到第二小的,一次类推,找到第三小的。。。。直到找不到为止,输出即为n-(连续的递减个数)。
详见代码。
#include<cstdio>
#include<iostream>
using namespace std;
int a[22];
int main()
{
int T, n, m;
while ( scanf("%d", &T) != EOF)
{
while ( T--)
{
scanf("%d", &n);
for ( int i=1; i<=n; i++)
{
scanf("%d", &a[i]);
}
int ii=n;
int r=n;
for (int i=1; i<=r; i++)
{
for (int j=1; j<=ii; j++)
{
if (a[j]==n)
{
ii=j;
n--;
break;
}
}
//printf ("%d\n",n);
}
printf ("%d\n",n);
}
}
return 0;
}