hdu -3502 Calculation 2

Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
   
   
   
   
3 4 0
 

Sample Output
   
   
   
   
0 2
 
#include<stdio.h>
#include<algorithm>
using namespace std;
const int F=1000000007;
__int64 ola(__int64 n){
	__int64 sum=n;
	for(int i=2;i*i<=n;i++){
		if(n%i==0)
		   sum-=sum/i;
		while(n%i==0)
		   n/=i;
	}
	if(n>1)
	   sum-=sum/n;
	return sum;
}
int main(){
	__int64 sum,n;
	while(~scanf("%I64d",&n),n!=0){
		sum=n*(n-1)/2;
		sum-=ola(n)*n/2;
		printf("%I64d\n",sum%F);
	}
}

你可能感兴趣的:(hdu -3502 Calculation 2)