1093. Count PAT's (25)

题目:

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2

注意:
1、这里用暴力求解可能会超时。
2、这里以A为遍历的参考,若遍历到的字符为A,则由这个A组成的PAT的个数就是这个A左边的P的个数乘以这个A右边的T的个数。
3、在遍历计算PAT个数之前,先遍历计算P和T在前i个字符中出现的次数。

代码:
//1093
#include<iostream>
#include<string>
using namespace std;

int main()
{
	string s;
	cin>>s;
	int P[100005]={0};//P[i] is the number of 'P' before the i-th element
	int T[100005]={0};//T[i] is the number of 'T' before the i-th element
	P[0] = s[0]=='P'?1:0;
	T[0] = s[0]=='T'?1:0;
	for(int i=1;i<s.size();++i)
	{
		P[i]=P[i-1];
		T[i]=T[i-1];
		if(s[i]=='P')
			++P[i];
		if(s[i]=='T')
			++T[i];
	}
	long count=0;//the number of "PAT"
	for(int i=1;i<s.size()-1;++i)
		if(s[i]=='A')
			count += P[i-1]*(T[s.size()-1]-T[i]);
	cout<<count%1000000007;
	return 0;
}


你可能感兴趣的:(考试,pat,浙江大学)