1022. Digital Library (30)

题目:

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
注意:
1、本题的难点在于keywords并不是一个而是多个word,因此在搜索这项时需要多个word分开,如果把他们放在一个字符串里面再匹配则会超时。
2、这里需要用到getline函数以及istringstream类的输入流,具体用法可以自行查询。
3、这里可以使用vector代替map,思路是一样的。

代码:
#include<iostream>
#include<map>
#include<vector>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;
//book information map:
//string:the 7-digit ID number
//vector<string>:
//the book title,author,key words,publisher,published year from vector[0] to vector[4]
map<string,vector<string>>books;
int N;//the total number of books

int main()
{
	cin>>N;
	getchar(); //to skip the [Enter] charactor of the first line
	for(int i=0;i<N;++i)
	{
		string ID,temp;
		vector<string> info;
		getline(cin,ID);
		for(int j=0;j<5;++j)
		{
			getline(cin,temp);
			info.push_back(temp);
		}
		books.insert(pair<string,vector<string>>(ID,info));
	}
	map<string,vector<string>>::iterator iter;
	vector<vector<string>> keywords;
	for(iter=books.begin();iter!=books.end();++iter)
	{
		istringstream stream(iter->second.at(2));
		string t;
		vector<string> s;
		s.clear();
		while(stream>>t)
			s.push_back(t);
		keywords.push_back(s);
	}
	int m;
	cin>>m;
	getchar();
	for(int i=0;i<m;++i)
	{
		int j;
		string key;
		scanf( "%d: ",&j);
		getline(cin,key);
		cout<<j--<< ": "<<key<<endl;//note that the input j need to decrease to be a correct index
		int count=0,k=0;
		for(iter=books.begin();iter!=books.end();++iter,++k)
			if( (j!=2 && iter->second.at(j)==key)
				||(j==2 && keywords[k].end()!=find(keywords[k].begin(),keywords[k].end(),key)) )
			{
				cout<<iter->first<<endl;
				++count;
			}
			if(count==0)
				cout<< "Not Found"<<endl;
	}
	return 0;
}

你可能感兴趣的:(考试,pat,浙江大学)