uva 111 History Grading(动态规划——最长公共子序列)

1、http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=47

2、题目很简单,不过题意好麻烦,开始误以为是求给出的序列的最长公共子序列,实际上题目要求的是rank的最长公共子序列,而题目给出的是各个event的序列,得先求出每个event的rank再求最长公共子序列,
状态转移方程:
            if(a[i]==b[j])
                dp[i][j]=dp[i-1][j-1]+1;
             else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

错了好几遍,超时了,输入时不能用while(1),改正后就对了

3、题目:

 

History Grading

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order.  Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events    as  where   denotes the ranking of eventi in the correct chronological order and a sequence of student responses   where   denotes the chronological rank given by the student to eventi; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with  .  The second line will containn integers, indicating the correct chronological order of nevents.  The remaining lines will each consist ofn integers with each line representing a student's chronological ordering of the n events. All lines will containn numbers in the range  , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking.  There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

 

4、ac代码:

#include<stdio.h>
#include<iostream>
using namespace std;
#define N 30
int a[N];
int b[N];
int dp[N][N];
int main()
{
    int n,t;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&t);
        a[t]=i;
    }
    while(scanf("%d",&t)!=EOF)//用while(1)超时
    {
        b[t]=1;
        for(int i=2;i<=n;i++)
        {
            scanf("%d",&t);
            b[t]=i;
        }

        for(int i=0;i<=n;i++)
        {
            dp[i][0]=0;
            dp[0][i]=0;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[i]==b[j])
                dp[i][j]=dp[i-1][j-1]+1;
                else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
//        for(int i=1;i<=n;i++)
//        {
//            for(int j=1;j<=n;j++)
//            printf("%d ",dp[i][j]);
//            printf("\n");
//        }
        printf("%d\n",dp[n][n]);
    }
    return 0;
}
/*
4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1
*/


 

你可能感兴趣的:(uva 111 History Grading(动态规划——最长公共子序列))