CRB and His Birthday
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 132 Accepted Submission(s): 72
Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with
M Won(currency unit).
At the shop, there are
N kinds of presents.
It costs
Wi Won to buy one present of
i -th kind. (So it costs
k ×
Wi Won to buy
k of them.)
But as the counter of the shop is her friend, the counter will give
Ai × x + Bi candies if she buys
x (
x >0) presents of
i -th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤
T ≤ 20
1 ≤
M ≤ 2000
1 ≤
N ≤ 1000
0 ≤
Ai, Bi ≤ 2000
1 ≤
Wi ≤ 2000
Input
There are multiple test cases. The first line of input contains an integer
T , indicating the number of test cases. For each test case:
The first line contains two integers
M and
N .
Then
N lines follow,
i -th line contains three space separated integers
Wi ,
Ai and
Bi .
Output
For each test case, output the maximum candies she can gain.
Sample Input
Sample Output
21
Hint
CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
Author
KUT(DPRK)
Source
2015 Multi-University Training Contest 10
背包问题。
特判每个状态是否可以由dp[i-cost]转移即可
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define maxn 2007
int dp[maxn];
int res[maxn];
int check[maxn];
int main(){
int t, m,n;
scanf("%d",&t);
while(t--){
scanf("%d%d",&m,&n);
memset(dp,0,sizeof(dp));
int cost,a,b;
for(int i = 0;i < n; i++){
scanf("%d%d%d",&cost,&a,&b);
memset(check,0,sizeof(check));
for(int i = 0;i <= m; i++)
res[i] = dp[i];
for(int i = cost; i <= m; i++){
if(res[i-cost] + a + b>= dp[i])
check[i] = 1;
res[i] = max(res[i],res[i-cost]+a);
}
for(int i = m;i >= 0; i--)
if(check[i] == 1)
res[i] = max(res[i],res[i-cost]+a+b);
for(int i = 0;i <= m; i++)
dp[i] = max(dp[i],res[i]);
}
int ans = 0;
for(int i = 0;i <= m; i++)
ans = max(ans,dp[i]);
printf("%d\n",ans);
}
return 0;
}