最短路___Frogger ( Poj 2253 )

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:给你n个点,每个点都是以坐标 x,y 的形式给出.每两个点都是可以相互连通的,其路径长度就是两点的几何距离.1号点到2号点的路径可能不止一条, 输出最大边的长度最短的路径对应的最大边的长度.


思路:一个简单的最短路径变形,只要将d[i]的意义变为从1到i的最大边即可.更新条件就是:

dis[next] = min( dis[next] , max ( dis[now] , mpt[now][next] ) )

应该还可以用最小生成树来做.


Dijkstra:

#include <stdio.h>
#include <string.h>
#include <math.h>
#define INF 99999999
struct node
{
	int x,y;
}point[210];
float mpt[210][210];
float dis[210];
int visit[210];
float Max(float a,float b)
{
	if( a>b)return a;
	return b;
}

void Dijkstra(int x,int n)
{
    int i,j;
    for(i = 1; i <= n ; i ++)
        dis[i] = mpt[x][i];
    memset(visit,0,sizeof(visit));
    visit[x] = 1;
    for(i = 1; i < n ; i ++)
    {
        int Minj = -1,Min = INF;
        for(j = 1; j <= n ; j ++)
        {
            if(visit[j]) continue;
            if( Min > dis[j])
            {
                Min = dis[j];
                Minj = j;
            }
        }
        if(Minj == -1)continue;
        visit[Minj] = 1;
        for(j = 1; j <= n ; j ++)
        {
            if(dis[j] > Max(dis[Minj],mpt[Minj][j])) dis[j] = Max(dis[Minj],mpt[Minj][j]);
        }
    }
}

int main()
{
	int n,i,j,Case = 1;
	while(scanf("%d",&n),n)
	{

		for(i = 1 ; i <= n ; i ++)
		{
			scanf("%d %d",&point[i].x,&point[i].y);
		}
		for(i = 1; i <= n ; i ++)
		{
			for(j = 1; j <= n ; j ++)
			{
				if( i == j ) mpt[i][j] = 0;
				else mpt[i][j] = INF;
			}
		}
		for(i = 1; i <= n ; i ++)
		{
			for(j = 1; j <= n ; j ++)
			{
				int tx = point[i].x -point[j].x;
				int ty = point[i].y -point[j].y;
				mpt[i][j] = sqrt(tx*tx + ty*ty);
			}
		}
		Dijkstra(1,n);
		printf("Scenario #%d\nFrog Distance = %.3f\n\n",Case++,dis[2]);

	}
	return 0;
}





你可能感兴趣的:(最短路径,dijkstra)