HDOJ 2199 Can you solve this equation?

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14483    Accepted Submission(s): 6461


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
   
   
   
   
2 100 -4
 

Sample Output
   
   
   
   
1.6152 No solution!
 
简单二分
#include <cstdio>
#include <iostream>
#include <cmath>
#include <algorithm>

using namespace std;
const int maxn = 100000 + 10;

double f(double x)
{
    return (8 * pow(x, 4) + 7 * pow(x, 3) + 2 * pow(x, 2) + 3 * x + 6);
}

int main()
{
    int t;
    double y;
    double i, j, middle;
    scanf("%d", &t);
    while (t--){
        scanf("%lf", &y);
        i = 1, j = 100;
        if (y < f(1) || y > f(100)){
            printf("No solution!\n");
            continue;
        }
        while (j - i > 1e-8){
            middle = (i + j) / 2;
            if (f(middle) > y)
                j = middle;
            else
                i = middle;
        }
        printf("%.4lf\n", middle);
    }
    return 0;
}


你可能感兴趣的:(HDOJ 2199 Can you solve this equation?)