1195: Prime Ring Problem
Result |
TIME Limit |
MEMORY Limit |
Run Times |
AC Times |
JUDGE |
|
10s |
8192K |
1939 |
493 |
Standard |
A ring is composed of n circles as shown in diagram. Put natural numbers into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n <= 16)
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.
You are to write a program that completes above process.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
This problem is used for contest: 102 150
Submit / Problem List / Status / Discuss
#include<cstdio>
int prime[33];
int visited[17];
int num[17];
void findprime()
{
for(int i=1;i<=32;i++)prime[i]=1;
for(int i=2;i<=16;i++)
{
for(int j=2;i*j<=32;j++)
{
prime[i*j]=0;
}
}
}
void print(int selected,int n)
{
if(selected==n)
{
if(prime[num[n]+1]==0)return ;
for(int i=1;i<n;i++)printf("%d ",num[i]);
printf("%d\n",num[n]);
return ;
}
for(int i=2;i<=n;i++)
{
if(visited[i]==0&&prime[i+num[selected]]==1)
{
visited[i]=1;
int m=selected+1;
num[m]=i;
print(m,n);
visited[i]=0;
}
}
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int n;
findprime();
int count=1;
while(scanf("%d",&n)==1)
{
printf("Case %d:\n",count++);
if(n!=1)
{
for(int i=1;i<=n;i++)visited[i]=0;
num[1]=1;
visited[1]=1;
print(1,n);
}
printf("\n");
}
return 0;
}