算法学习【16】—— 1119. Factstone Benchmark

题目来源:http://soj.me/1119

1119. Factstone Benchmark

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)

Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Input

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

Output

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8

思路:继续水题,这里题目抽象为求最大的n,能符合n! <= 2^bits,其中bits = 2 ^ ((year - 1996) / 10 + 2)。直接阶乘会溢出,用log中转下。因为有log(n*m) = log(n) + log(m)。然后就变成累加log(n) / log(2),使之大于bits了。(敲代码的时候犯了个小错误,没有考虑到log(n) / log(2)是个小数,囧。)

代码:

/*
Link:
Author: BetaBin http://soj.me/1119
Date: 2012/07/26
*/
/*
#include <stdio.h>

int main()
{
    int year;
    int answer[21] = {3,5,8,12,20,34,57,98,170,300,536,966,1754,3210,5910,10944,20366,38064,71421,134480,254016};
    while(scanf("%d", &year) && year)
    {
        printf("%d\n", answer[(year - 1960) / 10]);
    }
    return 0;
}
*/

#include <stdio.h>
#include <math.h>

//原来的错误,忽略了在相等情况下,小数的影响,取1960分析可得错误
//需要用double,而不应该是int

int main()
{
    int year;
    int endflag;
    int n;
    double sum;
    while(scanf("%d", &year) && year)
    {
        endflag = pow(2, (year - 1960) / 10 + 2);
        n = 2;
        sum = 0;

        while(sum <= endflag)
        {
            sum += log(n) / log(2);
            ++n;
        }
        printf("%d\n", n - 2);
    }
    return 0;
}


你可能感兴趣的:(算法,Date,Integer,input,each,output)