【UVaOJ】101 - The Blocks Problem


 The Blocks Problem 

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AIstudy of planning and robotics (STRIPS) used a block world in which arobot arm performed tasks involving the manipulation of blocks.

In thisproblem you will model a simple block world under certain rules andconstraints. Rather than determine how to achieve a specified state,you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot armin how to manipulate blocks that lie on a flat table. Initially thereare n blocks on the table (numbered from 0 to n-1)with block b i adjacent to block b i+1for all as shown in the diagram below:
 
Figure:Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b afterreturning any blocks that are stacked on top of blocks a and b totheir initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of thestack containing block b, after returning any blocks that are stackedon top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consistingof block a, and any blocks that are stacked above block a, ontoblock b. All blocks on top of block b are moved to their initialpositions prior to the pile taking place. The blocks stacked above blocka retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consistingof block a, and any blocks that are stacked above block a, ontothe top of the stack containing block b. The blocks stacked above blocka retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and bare in the same stack of blocks is an illegal command. All illegalcommands should be ignored and should have noaffect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representingthe number of blocks in the block world. You may assume that 0 < n <25.

The number of blocks is followed by a sequence of block commands, onecommand per line. Yourprogram should process all commands until the quit command isencountered.

You may assume that all commands will be of the form specified above.There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Eachoriginal block position numbered i (where n is the number of blocks) should appearfollowed immediately by a colon.If there is at least a blockon it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position(i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:


比较简单,直接贴代码

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <map>
#include <vector>
#include <algorithm>

using namespace std;

vector<vector<int> > block_table;
map<int,int> block_map;

void RemoveAboveBlock(int id) 
{
    int cur; // 当前坐在block号 
    int n;
    // 找到标号为id的block所在的堆 
    vector<int> &pile = block_table[block_map[id]];    
    while ((n = pile.back()) != id) {
        block_table[n].push_back(n); // 放回原位置
        block_map[n] = n;
        pile.pop_back();  // 从当前堆中移除 
    }
}

int main(int argc, char *argv[])
{	
    int n, a, b;
    string line, cmd, style;
    
    cin.sync_with_stdio(false);
    cout.sync_with_stdio(false);
    
    cin >> n;
    block_table.resize(n);
    for (int i = 0; i < n; ++i) {
        block_table[i].push_back(i);
        block_map[i] = i;
    }
    
    while(getline(cin, line) && line != "quit") {
        stringstream ss(line);
        ss >> cmd >> a >> style >> b;
        
        int pos_a = block_map[a];
        int pos_b = block_map[b];
        
        if (pos_a == pos_b) { 
            continue;
        }
        
        if (cmd == "move") {
            RemoveAboveBlock(a);
            if (style == "onto") {
                RemoveAboveBlock(b);
            }            
            block_table[pos_b].push_back(block_table[pos_a].back());
            block_table[pos_a].pop_back();
            block_map[a] = pos_b;
        } else { // cmd == "pile"
            if (style == "onto") {
                RemoveAboveBlock(b);  
            } 
            vector<int> &srcv = block_table[pos_a];           
            vector<int> &destv = block_table[pos_b];
            
            // 找到a在所在stack中的位置 
            auto start = find(srcv.begin(), srcv.end(), a);
            
            // 将a及其之上的block都移动到目标stack中 
            destv.insert(destv.end(), start, srcv.end());
            
            // 更改映射,然后移除 
            for (auto it = start ; it != srcv.end(); ++it) {
                block_map[*it] = pos_b;
            }
            srcv.erase(start, srcv.end());
        }
    }
    
    for (int i = 0; i < n; ++i) {
        cout << i << ":";
        for (int j = 0; j < block_table[i].size(); ++j) {
            cout << " " << block_table[i][j];
        }
        cout << "\n";
    }
    
	return 0;
}



你可能感兴趣的:(101,UvaOJ)