POJ 2386 Lake Counting

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26957   Accepted: 13541

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.


题意:
大小为N * M 的院子,积水了,八连通的积水被认为是连接在一起的,求总共有多少水洼?

#include <cstdio>
using namespace std;

char map[110][110];
int n, m;

void dfs(int x, int y)
{
    map[x][y] = '.';
    for (int dx = -1; dx <= 1; dx++){
        for (int dy = -1; dy <= 1; dy++){
            if (x + dx >= 0 && x + dx < n && y + dy >= 0 && y + dy < m && map[x + dx][y + dy] == 'W'){
                dfs(x + dx, y + dy);
            }
        }
    }
    return ;
}

int main()
{
    scanf("%d%d", &n, &m);
    int res = 0;
    for (int i = 0; i < n; i++){
        scanf("%s", map[i]);
    }
    for (int i = 0; i < n; i++){
        for (int j = 0; j < m; j++){
            if (map[i][j] == 'W'){
                dfs(i, j);
                res++;
            }
        }
    }
    printf("%d\n", res);
    return 0;
}


你可能感兴趣的:(POJ 2386 Lake Counting)