1058. A+B in Hogwarts

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
#include<stdio.h>
struct number
{
	int a;
	int b;
	int c;
};

int main()
{
	number num1, num2, sum;
	scanf("%d.%d.%d", &num1.a, &num1.b, &num1.c);
	scanf("%d.%d.%d", &num2.a, &num2.b, &num2.c);
	
	int flag = 0;
	sum.c = num1.c + num2.c;
	if(sum.c >= 29)
	{
		sum.c = sum.c % 29;
		flag = 1;
	}
	
	sum.b = num1.b + num2.b + flag;
	if(sum.b >= 17)
	{			
		sum.b = sum.b % 17;
		flag = 1;
	}
	else
		flag = 0;
	
	sum.a = num1.a + num2.a + flag;
	
	printf("%d.%d.%d\n", sum.a, sum.b, sum.c);
	return 0;
}


你可能感兴趣的:(1058. A+B in Hogwarts)