HDU1087 Super Jumping! Jumping! Jumping!

Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

这里写图片描述

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

##题解:
简单DP,dp[i]为走到第i个格子时最大的值
那么在第i个格子的时候有两种情况,要么是直接从起点过来的,要么是从i-1的格子中其中一个数值比它小的过来的,比较一下取最大即可

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;

int dp[1005];
int m[1005];
int main()
{
    int n;
    while (scanf("%d",&n) && n)
    {
        for (int i = 1;i<=n;i++)
          scanf("%d",&m[i]);
        dp[0] = 0;
        for (int i = 1;i<=n;i++)
        {
          dp[i] = m[i];
          for (int j = 1;j<=i;j++)
          {
           if (i == j)
            continue;
           if (m[j] < m[i])
             dp[i] = max(dp[i],dp[j]+m[i]);
          }
        }

        int maxn = 0;
        for (int i = 1;i<=n;i++)
         if (maxn < dp[i])
         maxn = dp[i];
        printf("%d\n",maxn);
        memset(dp,0,sizeof(dp));
        memset(m,0,sizeof(m));
    }
}





你可能感兴趣的:(HDU1087 Super Jumping! Jumping! Jumping!)