POJ 1018 Communication System(简单DP)

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices. 
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P. 

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point. 

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649

题意:

某公司要建立一套通信系统,该通信系统需要n种设备,而每种设备分别可以有m1、m2、m3、...、mn个厂家提供生产,而每个厂家生产的同种设备都会存在两个方面的差别:带宽bandwidths 和 价格prices。

现在每种设备都各需要1个,考虑到性价比问题,要求所挑选出来的n件设备,要使得B/P最大。

其中B为这n件设备的带宽的最小值,P为这n件设备的总价。


我们定义状态dp 【i】【j】 表示选择了前 i 个宽带其容量为 j 的最小费用。 

很容易得到转移方程 :dp【i】【j】=min(dp【i】【j】,dp【i-1】【k】+p);

注意选择 j 的时候的大小情况。



<span style="color:#333333;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf=99999999;
int dp[111][1200];
void init (int n)
{
	int i,j;
	for(i=1;i<=n;i++) {
		for(j=0;j<1200;j++)
		dp[i][j]=inf;
	}
}

int main()
{
	int t,n,i,j,num,a,b;
	cin>>t;
	while(t--) {
		cin>>n;
		init(n);
		for(i=1;i<=n;i++) {
			cin>>num;
			while(num--) {
				cin>>a>>b;
				if(i==1) {
					dp[1][a]=min(dp[1][a],b);
				}
				else {
					for(j=0;j<1200;j++) {
						if(dp[i-1][j]!=inf) {
							if(a>=j)  dp[i][j]=min(dp[i][j],dp[i-1][j]+b);
							else dp[i][a]=min(dp[i][a],dp[i-1][j]+b);
						}
					}
				}
			}
		}
		double ans=0;
		for(i=0;i<1200;i++) {
			if(dp[n][i]!=inf) {
				double k=(double)i/dp[n][i];
				if(k>ans) ans=k;
			}
		}
		printf("%.3lf\n",ans);
	}
	return 0;
}

</span><span style="color:#0000ff;">







</span>


你可能感兴趣的:(POJ 1018 Communication System(简单DP))