题目链接(POJ) :http://poj.org/problem?id=1458
题目链接(HDOJ):http://acm.hdu.edu.cn/showproblem.php?pid=1159
Common Subsequence
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 40156 |
|
Accepted: 16162 |
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x
ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
Source
Southeastern Europe 2003
题意: 求最长公共子序列长度
题解: 模板~~~
AC代码:
#include<iostream>
#include<cstring>
#include<string>
#define N 1005
using namespace std;
int dp[N][N],res;
string x,y;
int main()
{
cin.sync_with_stdio(false);
while(cin>>x>>y){
res=0;
memset(dp,0,sizeof(dp));
int lenx=x.size(),leny=y.size();
for(int i=1;i<=lenx;i++)
for(int j=1;j<=leny;j++)
if(x[i-1]==y[j-1])dp[i][j]=dp[i-1][j-1]+1;
else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
cout<<dp[lenx][leny]<<endl;
}
return 0;
}