POJ 2406 Power Strings

C - Power Strings
Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Submit Status

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

这题一开始根本没看明白是什么意思。

后来看了看输入输出样例,才明白了这题要干什么。

给出一个串,问你这个最多是多少个相同的字串重复连接而成的。

KMP里,用nxt[]表示模式串如果第i位(设a[0]为第0位)与文本串第j位不匹配,则要回到第nxt[i]位继续与文本串第j位匹配。则模式串第1位到nxt[l]与模式串第l-nxt[l]位到n位是匹配的。所以如果l%(l-nxt[l])==0,则存在重复连续子串,长度为l-nxt[l]。

#include <stdio.h>
#include <string.h>
#define N 1000005
char a[N];
int nxt[N];
int l;
void getnext(){
    int j, k;
    j = 0; k = -1; nxt[0] = -1;
    while(j<l){
        if (k==-1 || a[j]==a[k]){
            nxt[++j] = ++k;
        }
        else{
            k = nxt[k];
        }
    }
}
int main()
{
        while(scanf("%s",a)>0&&a[0]!='.')
        {
               l=strlen(a);
               getnext();
                if(l % (l - nxt[l]) == 0)
                        printf("%d\n",l / (l - nxt[l]));
                else
                        printf("1\n");
        }
        return 0;
}

另外,最近看KMP算法的时候,看到一篇对于理解很有用的文章。记录一下。

http://kb.cnblogs.com/page/176818/

你可能感兴趣的:(POJ 2406 Power Strings)