hdu 5437 Alisha’s Party(长春网络赛——优先队列)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5437

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4046    Accepted Submission(s): 1042


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases, T , where 1T15 .

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000 . The door would open m times before all Alisha’s friends arrive where 0mk . Alisha will have q queries where 1q100 .

The ith of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1vi108 , separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi .

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
   
   
   
   
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
   
   
   
   
Sorey Lailah Rose
 

Source
2015 ACM/ICPC Asia Regional Changchun Online
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5659  5658  5657  5656  5655 

题目大意:过生日接收礼物,他会选择礼物价值高的优先接收。
讲解一下测试数据:5 2 3 :5表示有5个人来给他送生日礼物,接下去5行,有每个人的名字以及带来礼物的价值;2表示有两个操作,接下去两行表示,来了1个人的时候开一次门,让1个人进来。来4个人的时候开一次门,让2个人进来。3表示有3个询问,问第1个人进来的是谁,第2二进来的是谁叫什么名字。。。以此类推。

解题思路:题目看上去比较清晰,用优先队列的方法对礼物的价值进行排序。
但是还有很多坑点:1、给出的操作顺序可能是乱序,需要进行排序。2、在最后的时候,会再开一次门,有多少人进多少人~~~3、输出的时候,最后一个没有空格4、优先队列每次要清空。

详见代码。
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;

struct node
{
    char name[200];
    int p;
    int num;//到达的先后
    bool friend operator < (node a,node b)
    {
        if (a.p==b.p)
            return a.num>b.num;
        return a.p<b.p;
    }
};

struct node1
{
    int op,np;
};

bool cmp(node1 a,node1 b)
{
    return a.op<b.op;
}

node s[150010];
node1 ss[150010];
int f[150000];
char str[150000][205];

int main()
{
    //q=qq;
    int t;
    scanf("%d",&t);
    while (t--)
    {
        priority_queue<node>q;
        int k,m,w,o=1;
        scanf("%d%d%d",&k,&m,&w);
        for (int i=1; i<=k; i++)
        {
            scanf("%s%d",s[i].name,&s[i].p);
            s[i].num=i;
        }
        for (int i=1; i<=m; i++)
        {
            scanf("%d%d",&ss[i].op,&ss[i].np);
        }

        sort(ss+1,ss+m+1,cmp);
        ss[0].op=0;
        for (int i=1; i<=m; i++)
        {
            for (int j=ss[i-1].op+1; j<=ss[i].op; j++)
            {
                q.push(s[j]);
            }
            int l=1;
            while (l<=ss[i].np)
            {
                if (q.empty())
                    break;
                node S=q.top();
                strcpy(str[o++],S.name);
                q.pop();
                l++;
            }//cout<<111111111<<endl;
        }
        for (int j=ss[m].op+1; j<=k; j++)
        {
            q.push(s[j]);
        }
        int l=1;
        while (!q.empty())
        {
            node S=q.top();
            strcpy(str[o++],S.name);
            q.pop();
            l++;
        }
        for (int i=1; i<w; i++)
        {
            scanf("%d",&f[i]);
            printf ("%s ",str[f[i]]);
        }
        scanf("%d",&f[w]);
        printf ("%s\n",str[f[w]]);
    }
    return 0;
}



 

你可能感兴趣的:(hdu 5437 Alisha’s Party(长春网络赛——优先队列))