uva 10391 Compound Words(stl map)

Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
题目大意:给出一些字符串,如果当前字符串可以由给出的如意两个字符串组成,输出。

解题思路:借助stl中的map,对出现的字符串进行标记,对于每个字符串呢,将字符串分层两段,判断分成的两段是否出现(两段长度要遍历一遍)。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
#include <string>
using namespace std;

const int N = 120005;
const int M = 30;
map<string, int> vec;

int main() {
    int n = 0;
    char str[N][M];

    while (gets(str[n]) != NULL) {
	vec[str[n++]] = 1;
    }

    for (int i = 0; i < n; i++) {
	int len = strlen(str[i]);
	for (int j = 0; j < len - 1; j++) {
	    char p[M], q[M];
	    strncpy(p, str[i], j);
	    p[j] = '\0';
	    for (int k = j; k < len; k++) 
		q[k - j] = str[i][k];
	    q[len - j] = '\0';
	    if (vec[p] + vec[q] == 2) {
		printf("%s\n", str[i]);
		break;
	    }
	}
    }
    return 0;
}

你可能感兴趣的:(uva 10391 Compound Words(stl map))