2015福建省赛 Common Tangents 2213 (简单数学几何)

 Problem 2213 Common Tangents

Accept: 6    Submit: 7
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

2015福建省赛 Common Tangents 2213 (简单数学几何)_第1张图片

Now given the center and radius of two circles, your job is to find how many common tangents between them.

 Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

 Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

 Sample Input

3
10 10 5 20 20 5
10 10 10 20 20 10
10 10 5 20 10 5

 Sample Output

4
2
3
//题意:
给你两个圆的圆心坐标和其对应的半径,问这两个圆的切线数目。
//思路:
判断相交,相离(包含和不包含),相切(外切和内切),重合。
具体看代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int x1,x2,y1,y2,r1,r2;
		double s1;
		scanf("%d%d%d%d%d%d",&x1,&y1,&r1,&x2,&y2,&r2);
		if(x1==x2&&y1==y2&&r1==r2)
			printf("-1\n");
		else
		{
			s1=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)); 
			if(1.0*(r1+r2)<s1)
				printf("4\n");
			else if(1.0*(r1+r2)==s1)
				printf("3\n");
			else if(r1+r2>s1)
			{
				if(s1+(min(r1,r2))*1.0==(max(r1,r2))*1.0)
					printf("1\n");
				else if(s1+1.0*(min(r1,r2))<1.0*(max(r1,r2)))
					printf("0\n");
				else 
					printf("2\n");
			}
		}
	}
	return 0;
}

你可能感兴趣的:(2015福建省赛 Common Tangents 2213 (简单数学几何))