HDU1181_BFS/DFS

Click me to HDU1181

变形课

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 10792    Accepted Submission(s): 4007

Problem Description
呃......变形课上Harry碰到了一点小麻烦,因为他并不像Hermione那样能够记住所有的咒语而随意的将一个棒球变成刺猬什么的,但是他发现了变形咒语的一个统一规律:如果咒语是以a开头b结尾的一个单词,那么它的作用就恰好是使A物体变成B物体. 
Harry已经将他所会的所有咒语都列成了一个表,他想让你帮忙计算一下他是否能完成老师的作业,将一个B(ball)变成一个M(Mouse),你知道,如果他自己不能完成的话,他就只好向Hermione请教,并且被迫听一大堆好好学习的道理.
Input
测试数据有多组。每组有多行,每行一个单词,仅包括小写字母,是Harry所会的所有咒语.数字0表示一组输入结束.
Output
如果Harry可以完成他的作业,就输出"Yes.",否则就输出"No."(不要忽略了句号)
Sample Input
   
   
   
   
so
soon
river
goes
them
got
moon
begin
big
0
Sample Output
   
   
   
   
Yes.
Hint
Hint
Harry 可以念这个咒语:"big-got-them".
 
思路:一个单词(实质上只有首尾字符有用),首尾字符可以连成一条边,那么整一组单词就可以构成一个有向图,从b->m可以看作一条路径,建立这张图之后,只需要用任何一种搜索算法(DFS or BFS)去遍历以b为起点的连通分支,如果能够遍历到m则说明答案是Yes.否则是No.看起来思路十分简单,代码也如是。下面是BFS版本的代码:
#include<iostream>
#include<algorithm>
#include<string>
#include<queue>
using namespace std;

const int MAX_INT = 0x7f7f7f7f;
const int beg = (int)('b'-'a'),end = (int)('m'-'a');

int map[27][27]; 
bool visited[27];
/*
void CreateMap()
{
	string str;
	memset(map,0x7f,sizeof(map));
	while( cin >>str && str != "0" )
	{
		map[*str.begin()-'a'][*str.rbegin()-'a'] = 1;
	}
}*/
bool FindThePath()//bfs or dfs
{
	queue<int> q;
	q.push(beg);
	int vex,i;

	while(!q.empty())
	{
		vex = q.front();
		q.pop();
		//cout << vex + 'a' <<' ';
		//printf("%c ",vex+'a');
		visited[vex] = true;
		for(i=0; i<26; ++i)
		{
			if(!visited[i] && map[vex][i] == 1)
			{
				if(i == end)
					return true;
				q.push(i);
			}
		}
	}
	return false;
}
int main()
{
	//CreateMap();
	string str;
	
	while( cin >>str )
	{
		memset(visited,false,sizeof(visited));
		memset(map,0x7f,sizeof(map));
		while(str != "0")
		{
			map[*str.begin()-'a'][*str.rbegin()-'a'] = 1;
			cin >> str;
		}
		if(FindThePath())
			cout <<"Yes."<< endl;
		else
			cout <<"No."<<endl;
	}
	return 0;
}
DFS代码

#include<iostream>
#include<algorithm>
#include<string>
#include<queue>
using namespace std;

const int MAX_INT = 0x7f7f7f7f;
int end = (int)('m'-'a');

int map[27][27]; 
bool visited[27];

int NextAdjVex(int vex,int w)
{
	for(int i=w; i<26; ++i)
	{
		if( !visited[i] && map[vex][i] == 1 )
			return i;
	}
	return -1;
}

bool isDone;
void DFS(int vex)//bfs or dfs
{
	if ( isDone )
		return;
	if( vex == end )
	{
		isDone = true;
		return ;
	}

	visited[vex] = true;
	int w = NextAdjVex(vex,0);
	while(!isDone && w>=0)
	{
		DFS(w);
		w = NextAdjVex(vex,w); // vex is adj with w
	}
}
int main()
{
	string str;
	int beg;
	while( cin >>str )
	{
		memset(visited,false,sizeof(visited));
		memset(map,0x7f,sizeof(map));
		while(str != "0")
		{
			map[*str.begin()-'a'][*str.rbegin()-'a'] = 1;
			cin >> str;
		}
		isDone = false;
		beg = (int)('b'-'a');
		DFS(beg);
		if(isDone)
			cout <<"Yes."<< endl;
		else
			cout <<"No."<<endl;
	}
	return 0;
}


你可能感兴趣的:(数据,测试,DFS,bfs)