最长有序子序列 Longest Ordered Subsequence POJ2533

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 29968   Accepted: 13066

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
最长上升子序列:
#include<iostream>
#include<string.h>
using namespace std;
int D[10000];
int binarysearch(int low,int high,int m)//二分查找
{
	int mid;
	mid=(low+high)/2;
	while(low<=high)
	{
		if(D[mid]<m&&D[mid+1]>=m)
			return mid;
		else
			if(D[mid]<m)
				low=mid+1;
			else
				high=mid-1;
		mid=(low+high)/2;
	} 
	return mid;
}   
int main()
{
	int a[10000];
	int n,i,j,k,len;
	while(cin>>n)
	{
		for(i=1;i<=n;++i)
			cin>>a[i];
		D[1]=a[1];
		len=1;
		for(i=2;i<=n;i++)
		{
			if(a[i]>D[len])
			{
				len++;
				D[len]=a[i];
			}
			else
			{
				j=binarysearch(1,len,a[i]);
				k=j+1;
				D[k]=a[i];
			} 
		}  
	cout<<len<<endl;  
}
	return 0;
}


你可能感兴趣的:(最长有序子序列 Longest Ordered Subsequence POJ2533)