Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13268 Accepted: 7886
Description
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
题目大意:一个完备的括号串(即所有括号都可以成功匹配)可以以2种编码方式编码
P型编码,在右括号出现的位置的值为,之前左括号出现的次数。
W型编码,在右括号出现的位置的值为,一个以该括号为终点的子完备括号串中右括号的个数。
输入一个括号串的P型编码,要求求出W型编码。
代码:
#include<iostream>
using namespace std;
int p[22];
int w[22];
int main()
{
int t;
cin>>t;
int n;
while(t--)
{
cin>>n;
for(int i=1;i<=n;i++)
cin>>p[i];
w[0] = 0;
p[0] = 0;
for(int i=1;i<=n;i++)
{
int val = p[i]-p[i-1];
if(val>0)
{
w[i] = 1;
}
else
{
int temp = 1;
int cnt = 1;
for(int j=i;j>=1;j--)
{
temp--;
temp+=p[j]-p[j-1];
if(temp>0)
{
w[i] = cnt;
break;
}
else
cnt++;
}
}
}
for(int i=1;i<=n;i++)
{
if(i!=1)
cout<<" "<<w[i];
else
cout<<w[i];
}
cout<<endl;
}
return 0;
}