Poj 1325 Machine Schedule

Machine Schedule
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9566   Accepted: 4068

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

虽然这题在想到如何构图的情况下变成模版题了,但我是死活想不出这样来建图:把A 的n 个mode 和B 的m 个mode 看作图的顶点,如果某个任务可以
在A 的mode_i 或B 的mode_j 上完成,则从Ai 到Bj 连接一条边,这样构造了一个二部图。

本题要求二部图的最小点覆盖集问题,即求最小的顶点集合,“覆盖”住所有的边。转换成求二部图的最大匹配问题,因为:二部图的点覆盖数α0 = 匹配数β1。(这个等式早忘了)........

                另外A和B最初工作模式为0,所以此种模式能完成的任务  可以不予考虑。

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <set>
#include <queue>
#include <stack>
#include <climits>//形如INT_MAX一类的
#define MAX 105
#define INF 0x7FFFFFFF
# define eps 1e-5
using namespace std;
int mark[MAX],edge[MAX][MAX],visit[MAX];
int n,m,k;

int dfs(int u)
{
    int i,j;
    for(i=0; i<m; i++)
    {
        if(edge[u][i] && visit[i] == 0)
        {
            visit[i] = 1;
            if(mark[i] == -1 || dfs(mark[i]) )
            {
                mark[i] = u;
                return 1;
            }
        }
    }
    return 0;
}

void match()
{
    int i,sum = 0;
    memset(mark,-1,sizeof(mark));
    for(i=0; i<n; i++)
    {
        memset(visit,0,sizeof(visit));
        if(dfs(i))
        {
            sum++;
        }
    }
    cout << sum << endl;
}

int main()
{
    int i,j,x,y,job;
    while(cin >> n && n)
    {
        cin >> m >> k;
        memset(edge,0,sizeof(edge));
        for(i=0; i<k; i++)
        {
            cin >> job >> x >> y;
            if(x != 0 && y != 0)
            edge[x][y] = 1;
        }
        match();
    }
    return 0;
}


你可能感兴趣的:(Poj 1325 Machine Schedule)