我的第一个 USACO Training--Your Ride Is Here

题目:

Your Ride Is Here

It is a well-known fact that behind every good comet is a UFO. These UFOs often come to collect loyal supporters from here on Earth. Unfortunately, they only have room to pick up one group of followers on each trip. They do, however, let the groups know ahead of time which will be picked up for each comet by a clever scheme: they pick a name for the comet which, along with the name of the group, can be used to determine if it is a particular group's turn to go (who do you think names the comets?). The details of the matching scheme are given below; your job is to write a program which takes the names of a group and a comet and then determines whether the group should go with the UFO behind that comet.

Both the name of the group and the name of the comet are converted into a number in the following manner: the final number is just the product of all the letters in the name, where "A" is 1 and "Z" is 26. For instance, the group "USACO" would be 21 * 19 * 1 * 3 * 15 = 17955. If the group's number mod 47 is the same as the comet's number mod 47, then you need to tell the group to get ready! (Remember that "a mod b" is the remainder left over after dividing a by b; 34 mod 10 is 4.)

Write a program which reads in the name of the comet and the name of the group and figures out whether according to the above scheme the names are a match, printing "GO" if they match and "STAY" if not. The names of the groups and the comets will be a string of capital letters with no spaces or punctuation, up to 6 characters long.

Examples:

Input Output
COMETQ
HVNGAT
GO
ABSTAR
USACO 
STAY

PROGRAM NAME: ride

This means that you fill in your header with:
PROG: ride

INPUT FORMAT

Line 1: An upper case character string of length 1..6 that is the name of the comet.
Line 2: An upper case character string of length 1..6 that is the name of the group.

NOTE: The input file has a newline at the end of each line but does not have a "return". Sometimes, programmers code for the Windows paradigm of "return" followed by "newline"; don't do that! Use simple input routines like "readln" (for Pascal) and, for C/C++, "fscanf" and "fid>>string".

SAMPLE INPUT (file ride.in)

COMETQ
HVNGAT

OUTPUT FORMAT

A single line containing either the word "GO" or the word "STAY".

SAMPLE OUTPUT (file ride.out)

GO


我的答案:

/*
ID: yang4521
LANG: JAVA
TASK: ride
*/
import java.io.*;
import java.util.*;


class ride {


public static void main(String[] args) throws IOException {

   BufferedReader f = new BufferedReader(new FileReader("ride.in"));
                                              
   PrintWriter out = new PrintWriter(new BufferedWriter(new FileWriter("ride.out")));
   String s1 = f.readLine();    //  get comet
   String s2 = f.readLine();    // get  group
	int num1=1;
	int num2=1;
	for(int i=0;i<s1.length();i++){ 
	char ch1 = s1.charAt(i);
	num1*=(int)ch1-64;
	}
	for(int i=0;i<s2.length();i++){ 
	char ch2 = s2.charAt(i);
	num2*=(int)ch2-64;
	}
	if((num1%47)==(num2%47))
  	 // output result
	out.println("GO");
	else
	out.println("STAY");
                  

 	 // close the output file
  
  	 out.close();  // don't omit this!
	System.exit(0);
 }


}


Analysis: Your Ride Is Here

This is probably the easiest problem in the entire set of lessons. An `ad hoc' problem, no particular algorithms or tricks are needed save one: one must be careful to get all 72 characters of input without processing the newline on the end!

Here is a prototype solution:

#include <stdio.h>
#include <ctype.h>

int
hash(char *s)
{
	int i, h;

	h = 1;
	for(i=0; s[i] && isalpha(s[i]); i++)
		h = ((s[i]-'A'+1)*h) % 47;
	return h;
}

void
main(void)
{
	FILE *in, *out;
	char comet[100], group[100];  /* bigger than necessary, room for newline */

	in = fopen("input.txt", "r");
	out = fopen("output.txt", "w");

	fgets(comet, sizeof comet, in);
	fgets(group, sizeof group, in);

	if(hash(comet) == hash(group))
		fprintf(out, "GO\n");
	else
		fprintf(out, "STAY\n");
	exit (0);
}

Solutions generally run in under 0.01 seconds.



之前一直输出是GO,原来是num1和num2一开始的时候自己初始化为0了,所以导致if((num1%47)==(num2%47)) 一直是true。粗心了


你可能感兴趣的:(我的第一个 USACO Training--Your Ride Is Here)