杭电1018 Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
   
   
   
   
2 10 20

Sample Output
   
   
   
   
7

19

//digits 位数,输入n,求N!的位数

#include<stdio.h>
#include<math.h>
int main()
{
    int t,n,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double result=0;
        for(i=1;i<=n;++i)
        {
            result+=log10((double)i);
        }
        printf("%d\n",(int)result+1);
    }
    return 0;
}


你可能感兴趣的:(杭电1018 Big Number)