杭电-The Last Practice

The Last Practice

Problem Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

Tips:
60=2^2*3^1*5^1

被坑了无数次的我代码如下
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <iomanip>
using namespace std;

int main()
{
    int n,num,th= 1;
    while (cin>>n&& n > 0)
    {
        if (th!=1) cout<<endl;
        cout<<"Case "<<th++<<"."<<endl;
        for (int i=2;i<=n;++i)
        {
            num=0;
            if (n%i==0)
            {
                cout<<i<<" ";
            }
            while (n%i==0)
            {
                num++;
                n/=i;
            }
            if (num>0) cout<<num<<" ";
        }
        cout<<endl;
    }
    return 0;
}
心得:
非常暴力的解法,其实我在网上看到有人先求2的,效率更高一些,不过先这样吧,已经被逼疯。。。
图片:


你可能感兴趣的:(杭电-The Last Practice)