hdoj ASCII码排序

Problem Description

输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。

Input

输入数据有多组,每组占一行,有三个字符组成,之间无空格。

Output

对于每组输入数据,输出一行,字符中间用一个空格分开。

Sample Input

qwe
asd
zxc

Sample Output

e q w
a d s
c x z
代码:
#include<stdio.h>
int main()
{ 
 char a,b,c;
 while(scanf("%c %c %c",&a,&b,&c)!=EOF)
 {
     getchar();
  if(a<=b)
  {
if(b<=c)
  printf("%c %c %c\n",a,b,c);
  else if(a<=c) 
printf("%c %c %c\n",a,c,b);
  else printf("%c %c %c\n",c,a,b);
  }
  else 
  {
    if(a<=c) 
printf("%c %c %c\n",b,a,c);
    else if(b<=c) 
printf("%c %c %c\n",b,c,a);
    else 
printf("%c %c %c\n",c,b,a);
  }
 }
 return 0;
}
 注意:char的用法以及getchar();每次运行时将以前的数据消除

你可能感兴趣的:(hdoj ASCII码排序)