[poj 1925] Spiderman 简单dp

Spiderman
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6751 Accepted: 1346

Description
Dr. Octopus kidnapped Spiderman’s girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web.

From Spiderman’s apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can’t hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman’s swings, he can never go backwards.

You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

Input
The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

Output
For each test case, output one line containing the minimum number of swings (if it’s possible to reach the tower) or -1 if Spiderman can’t reach the tower.

Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4

Sample Output

3
-1

Source
Beijing 2004 Preliminary@POJ
[poj 1925] Spiderman 简单dp_第1张图片

题目链接:http://poj.org/problem?id=1925

题意:MARVEL蜘蛛侠Peter Parker荡秋千;
给出n个建筑,每个建筑以两个数x,y表示,x代表它在横轴上的位置,y代表这个建筑的高度。所有建筑的高度都大于等于第一个建筑的高度。所有建筑输入顺序按照x,y从小到达的顺序排列。

思路
1.处理能荡i号建筑的条件:即不撞地;
边界从一号公寓算:
dis=sqrt(q[i].yq[i].y(q[i].yq[1].y)(q[i].yq[1].y)) 
1-dis中作起点,终点为q[i].x+2*(q[i].x-st);

2.dp[i]表示到i最小步数,每次+1更新;
初始dp[q[1].x]=0;

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<cmath>
using namespace std;
int dp[1000005];
struct node{
    long long   x,y;
}q[5050];

int n;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)   scanf("%lld%lld",&q[i].x,&q[i].y);
        memset(dp,-1,sizeof(dp));
        dp[q[1].x]=0;
        for(int i=2;i<=n;i++)
        {
            int dis=sqrt(q[i].y*q[i].y-(q[i].y-q[1].y)*(q[i].y-q[1].y));
            for(int j=1;j<=dis;j++)
            {
                if(q[i].x-j<q[1].x) break;
                if(dp[q[i].x-j]==-1) continue;
                else 
                {
                    int tt=min(q[i].x+j,q[n].x);
                    if(dp[tt]==-1||dp[tt]>dp[q[i].x-j]+1) dp[tt]=dp[q[i].x-j]+1;
                }
            }
        }
        printf("%d\n",dp[q[n].x]);
    }


}

你可能感兴趣的:(dp,poj)