超时杭电1005


A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
   
   
   
   
1 1 3 1 2 10 0 0 0
 

Sample Output
   
   
   
   
2 5
 

Author
CHEN, Shunbao
题目简单的要死啊,一个十位数就会超时啊,所以他一定有规律啊,但就是发现不了,看来别人的博客才知道规律是49,我简直不服啊。。。。。。
AC代码:
#include<stdio.h>
#include<math.h>
int main()
{
    int n,m,d,sum[50];
    int i;
    while(scanf("%d%d%d",&n,&m,&d)!=EOF&&n){
        sum[0]=1;
        sum[1]=1;
        sum[2]=1;
        for(i=3;i<50;i++){
             sum[i]=(n*sum[i-1]+m*sum[i-2])%7;
        }
        printf("%d\n",sum[d%49]);
    }
    return 0;
}
菜的要死了,啊啊啊,继续努力,见得太少,被水题卡N次的人。。。。。

你可能感兴趣的:(超时)