Alisha’s Party
Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4116 Accepted Submission(s): 1058
Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value
v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.
Each time when Alisha opens the door, she can decide to let
p people enter her castle. If there are less than
p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.
If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query
n Please tell Alisha who the
n−th person to enter her castle is.
Input
The first line of the input gives the number of test cases,
T , where
1≤T≤15 .
In each test case, the first line contains three numbers
k,m and
q separated by blanks.
k is the number of her friends invited where
1≤k≤150,000 . The door would open m times before all Alisha’s friends arrive where
0≤m≤k . Alisha will have
q queries where
1≤q≤100 .
The
i−th of the following
k lines gives a string
Bi , which consists of no more than
200 English characters, and an integer
vi ,
1≤vi≤108 , separated by a blank.
Bi is the name of the
i−th person coming to Alisha’s party and Bi brings a gift of value
vi .
Each of the following
m lines contains two integers
t(1≤t≤k) and
p(0≤p≤k) separated by a blank. The door will open right after the
t−th person arrives, and Alisha will let
p friends enter her castle.
The last line of each test case will contain
q numbers
n1,...,nq separated by a space, which means Alisha wants to know who are the
n1−th,...,nq−th friends to enter her castle.
Note: there will be at most two test cases containing
n>10000 .
Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
Sample Input
1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3
Sample Output
Source
2015 ACM/ICPC Asia Regional Changchun Online
优先级排序的题目;
题意是 女主人会在第i个人到来的时候将门打开,并让j个人进来,进入房子的顺序是按照礼物的贵重程度排序的,礼物价值高的先进入,价值相同则先到的先进入;当所有人都到的时候,会再开一次门让所有的人都进入。
按优先级排序即可,用数组记录第i个进入的人是谁就可以了。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
int t,w,i;
friend bool operator < (node a,node b)
{
if(a.w==b.w)
return a.t>b.t;
return a.w<b.w;
}
}e[150010];
struct pp
{
int a,b;
}P[150010];
char ch[150010][205];
int flag[150010];
int st,len,n;
priority_queue<node >q;
void que(int a,int b)
{
int i;
for(i=st;i<a;i++)
{
q.push(e[i]);
}
st=i;
for(i=0;i<b&&q.size();i++)
{
flag[i+len]=q.top().i;
//cout<<ch[q.top().i]<<endl;
q.pop();
}
len+=i;
return ;
}
bool cmp(pp a,pp b)
{
return a.a<b.a;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int k,p;
scanf("%d%d%d",&n,&k,&p);
for(int i=0;i<n;i++)
{
scanf("%s%d",ch[i],&e[i].w);
e[i].t=i+1;
e[i].i=i;
}
st=0;
len=0;
for(int i=0;i<k;i++)
{
scanf("%d%d",&P[i].a,&P[i].b);
}
sort(P,P+k,cmp);
for(int i=0;i<k;i++)
que(P[i].a,P[i].b);
for(int i=st;i<n;i++)
q.push(e[i]);
while(q.size())
flag[len++]=q.top().i,q.pop();
while(p--)
{
int a;
scanf("%d",&a);
a--;
if(p>0)
{
printf("%s ",ch[flag[a]]);
}
else printf("%s\n",ch[flag[a]]);
}
}
return 0;
}