HDU 4493 Tutor(四舍五入 模拟)

Tutor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3712    Accepted Submission(s): 970


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
   
   
   
   
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
   
   
   
   
$1581.42 $100
 

Source

这一题真的是坑啊。。。。题意就是给出每个月的工资,然后求平均数,主要就是题目的那一句It will be rounded to the nearest penny。。比如说除以12之后的数值为1.44499999   如果不加处理得到的答案就是1.45 但是要最接近,所以答案应该是1.44  

于是,主要判断小数点的第三位是不是大于5,大于的话前面以为加一,否则不加,

在这一题中,我们直接把sum扩大1000倍,然后加上5,再除以10,判断商是不是0来输出。主要看代码

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
	int i,j,k,m,n;
	int t;
	int g,l;
	double money;
	double sum;

	cin>>t;
	while(t--)
	{
		sum = 0;
		for(i=1;i<=12;i++)
		{
			cin>>money;
			sum += money;
		}

		sum /= 12;
		sum *= 1000;

		int a = sum+5;
		a /= 10;
		
		if(a%10 != 0)
			printf("$%.2lf\n",a*1.0/100);
		else
			if(a%100 != 0)
				printf("$%.1lf\n",a*1.0/100);
			else
				printf("$%d\n",a/100);
	}
	return 0;
}


你可能感兴趣的:(HDU 4493 Tutor(四舍五入 模拟))