杭电ACM---1003(水过)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 207258    Accepted Submission(s): 48469


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
   
   
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
   
   
   
   
Case 1: 14 1 4 Case 2: 7 1 6

代码:

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int t=input.nextInt();
        int c=0;
        while (t-->0){
            int n=input.nextInt();
            int a;
            int start=0;
            int end=0;
            int max=-1001;
            int sum=0,z=0;
            for (int i=0;i<n;i++){
                a=input.nextInt();
                sum+=a;
                if (sum>max){
                    max=sum;
                    start=z;
                    end=i;
                }
                if(sum<0) {
                    sum=0;
                    z=i+1;
                }
            }
            if (c++>0){
                System.out.println();
            }
            System.out.println("Case "+c+":");
            System.out.println(max+" "+(start+1)+" "+(end+1));
        }
    }
}


你可能感兴趣的:(java,算法,杭电)