HDU 5655 CA Loves Stick

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1502    Accepted Submission(s): 463


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains T denoting the number of testcases.
T testcases follow. Each testcase contains four integers a,b,c,d in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
   
   
   
   
2 1 1 1 1 1 1 9 2
 

Sample Output
   
   
   
   
Yes No
 

Source
BestCoder Round #78 (div.2)
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5674  5673  5672  5671  5670 
题意:给出四条边,看能不能组成四边形,也就是最长边小于另外三条边之和,由于给出数的范围比较大  0a,b,c,d2631 ,所以做一下变形,最小的边大于最长的边减去另外两条边
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	__int64 a[5];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d%I64d%I64d%I64d",&a[0],&a[1],&a[2],&a[3]);
		sort(a,a+4);
		if(a[0]==0)//注意 
		{
			printf("No\n");
			continue;
		}
		if(a[3]-a[2]-a[1]<a[0])
		printf("Yes\n");
		else
		printf("No\n");
	}
	return 0;
}




 

你可能感兴趣的:(HDU 5655 CA Loves Stick)