1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

提交代码

http://www.patest.cn/contests/pat-a-practise/1009

主要借助map<int,double>来实现

#include <cstdio>  
#include <cmath>
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <iterator>

using namespace std;

#define N 16

struct poly{
	int ni ;
	double ai ;
};

map<int , double> um ;

int main()
{
	//freopen("in.txt" , "r" , stdin) ;
	int n1 , n2 ;
	int i ;
	vector<poly> p1 ;
	poly pt ;
	scanf("%d" , &n1) ;
	for(i = 0 ;i < n1 ;i ++)
	{
		scanf("%d%lf" , &pt.ni , &pt.ai) ;
		p1.push_back(pt) ;
	}
	scanf("%d" , &n2) ;
	for(i = 0 ;i < n2 ;i ++)
	{
		scanf("%d%lf" , &pt.ni , &pt.ai) ;
		for(int j = 0 ; j < n1 ; j ++)
		{
			poly pt1 = p1[j];
			poly newPoly ;
			newPoly.ni = pt1.ni + pt.ni ;
			newPoly.ai = pt1.ai * pt.ai ;
			um[newPoly.ni] += newPoly.ai ;
		}
	}
	vector<poly> rs  ;
	int rsLen = 0 ;
	map<int , double>::iterator it = um.begin() ;
	while(it != um.end())
	{
		pt.ni = it->first;
		pt.ai = it->second ;
		if(fabs(pt.ai) > 1e-10)
		{
			rs.push_back(pt) ;
			rsLen ++ ;
		}
		it ++ ;
	}
	printf("%d",rsLen) ;
	for(i = rsLen - 1 ; i >= 0; i --)
	{
		printf(" %d %.1lf" , rs[i].ni , rs[i].ai );
	}
	printf("\n") ;
	return 0 ;
}


你可能感兴趣的:(1009. Product of Polynomials (25))