POJ Knight Moves(BFS呀,但也有坑呀)

Knight Moves
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23833   Accepted: 11202

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 
POJ Knight Moves(BFS呀,但也有坑呀)_第1张图片

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Source

TUD Programming Contest 2001, Darmstadt, Germany


原题链接:http://poj.org/problem?id=1915

题意:马踏棋盘,从一个点到另外一个点至少要走多少步.

AC代码:

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
#define maxn 305
bool vis[maxn][maxn];
int a[maxn][maxn];
int n,sx,sy,ex,ey;
int dir[8][2]={-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,-2,-2,-1};
struct node
{
    int x,y,step;
};
bool OK(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<n)
        return true;
    else
        return false;
}
int BFS()
{
    queue<node>q;
    node start,mid,next;
    start.x=sx;
    start.y=sy;
    start.step=0;
    q.push(start);
    while(!q.empty())
    {
        mid = q.front();
        q.pop();
        if(mid.x == ex && mid.y == ey)
            return mid.step;
        for(int i = 0; i<8; i++)
        {
            next.x = mid.x+dir[i][0];
            next.y = mid.y+dir[i][1];
            if(next.x == ex && next.y == ey)
                return mid.step+1;
            if (OK(next.x,next.y)&&!vis[next.x][next.y])
            {
                next.step=mid.step+1;
                vis[next.x][next.y]=true;
                q.push(next);
            }
        }
    }
    return 0;//少了这句你试试!!!!!!!
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        cin>>sx>>sy;
        cin>>ex>>ey;
        memset(vis,false,sizeof(vis));
        vis[sx][sy]=true;
        cout<<BFS()<<endl;
    }
    return 0;
}



你可能感兴趣的:(Moves,Knight,poj1915)