HDU 2028 Lowest Common Multiple Plus(求多个数的最小公倍数,转换呀)

Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49348    Accepted Submission(s): 20401


Problem Description
求n个数的最小公倍数。
 

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
 

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
 

Sample Input
   
   
   
   
2 4 6 3 2 5 7
 

Sample Output
   
   
   
   
12 70
 

Author
lcy
 

Source

C语言程序设计练习(五)


原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2028

思路:根据公式GCD(a,b)*LCM(a,b)=a*b;如果直接求最小公倍数的话可能会使得最后的结果超出范围而导致WA,

所以先求出GCD,

AC代码:

#include <iostream>
using namespace std;
int GCD(int x,int y)
{
    return y==0?x:GCD(y,x%y);
}
int main()
{
    int n,x;
    while(cin>>n)
    {
        int ans=1;
        for(int i=0;i<n;i++)
        {
            cin>>x;
            ans=x/GCD(ans,x)*ans;
        }
         cout<<ans<<endl;

    }
    return 0;
}



你可能感兴趣的:(common,lowest,HDU2028,Multip)