Hdu 2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17741    Accepted Submission(s): 7467


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
   
   
   
   
3 5 5 2 4 3 3 3
 

Sample Output
   
   
   
   
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
HDOJ 2009 Summer Exercise(5)


题意:有一块板,规格为h*w,然后有n张海报,每张海报的规格为1*wi,选择贴海报的位置是:尽量高,同一高度,选择尽量靠左的地方。要求输出每张海报的高度位置。

 

思路:

相当于查询[1,n]中能容下当前位置的i的最小值。

那么我们预处理线段树的每个位置都是w,然后查询大于等于当前位置wii的最小值,然后更新i位置为原来的可放的宽度-wi

 
#include<bits/stdc++.h>
using namespace std;
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int maxn=200100;
int maxv[maxn*4];
int h,w,n,pos,v;

void build(int l,int r,int rt){
    maxv[rt]=w;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(lson);
    build(rson);
}

void pushup(int rt){
    maxv[rt]=max(maxv[rt<<1],maxv[rt<<1|1]);
}

int query(int l,int r,int rt){
    if(l==r){
        maxv[rt]-=w;
        return l;
    }
    int mid=(l+r)>>1,ans=-1;
    if(maxv[rt<<1]>=w)
        ans=query(lson);
    if(maxv[rt<<1|1]>=w&&ans==-1)
        ans=query(rson);
    pushup(rt);
    return ans;
}

int main(){
    while(scanf("%d%d%d",&h,&w,&n)!=EOF){
        h=min(h,n+1);
        build(1,h,1);
        for(int i=1;i<=n;i++){
            scanf("%d",&w);
            int num=query(1,h,1);
            printf("%d\n",num);
        }
    }
    return 0;
}


你可能感兴趣的:(Hdu 2795 Billboard)