UVA 10970 Big Chocolate(水题)

题面:

Big Chocolate

Mohammad has recently visited Switzerland. As he loves his friends very much, he decided to buy some chocolate for them, but as this fine chocolate is very expensive(You know Mohammad is a little BIT stingy!), he could only afford buying one chocolate, albeit a very big one (part of it can be seen in figure 1) for all of them as a souvenir. Now, he wants to give each of his friends exactly one part of this chocolate and as he believes all human beings are equal (!), he wants to split it into equal parts.

The chocolate is an   rectangle constructed from   unit-sized squares. You can assume that Mohammad has also   friends waiting to receive their piece of chocolate.

To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines that separate the squares). Then, he should do the same with each part separately until he reaches   unit size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the minimum number of cuts required to accomplish this task.

Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares apart.

 

Figure 1. Mohammad’s chocolate

 

The Input

The input consists of several test cases. In each line of input, there are two integers  , the number of rows in the chocolate and  , the number of columns in the chocolate. The input should be processed until end of file is encountered.

 

The Output

For each line of input, your program should produce one line of output containing an integer indicating the minimum number of cuts needed to split the entire chocolate into unit size pieces.

 

Sample Input

2 2

1 1

1 5

 

Sample Output

3

0

4


题面:

    给定一块巧克力,问最少切多少刀,可以切成MxN块,分开两块不可以一起切。


解题:

    算是找规律吧,N*N的切的数量是以2阶等差递增的,而N*M的可以从N*N推出来,每次增加N,(N<M)


代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <cstdio>
#include <map> 
using namespace std;
int start[310]={0,0};
int main()
{
for(int i=2;i<=300;i++)
start[i]=start[i-1]+2*i-1;
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
       if(n<=m)
    printf("%d\n",start[n]+(m-n)*n);
  else
    printf("%d\n",start[m]+(n-m)*m);
    }
return 0;
}

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <cstdio>
#include <map> 
using namespace std;
int start[310]={0,0};
int main()
{
	for(int i=2;i<=300;i++)
		start[i]=start[i-1]+2*i-1;
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
       if(n<=m)
	     printf("%d\n",start[n]+(m-n)*n);
	   else
	     printf("%d\n",start[m]+(n-m)*m);	
    }
	return 0;
}


你可能感兴趣的:(入门,uva,规律)