Check the difficulty of problems
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 5862 |
|
Accepted: 2555 |
Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.
Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.
Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?
Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0
Sample Output
0.972
Source
POJ Monthly,鲁小石
<span style="color:#cc0000;">题意:有t支队伍,m道题,冠军最少做n道题,问保证每队最少做一题,冠军最少做n题的概率</span>
#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int m,t,n;
double dp[1005][35][35],s[1005][35],p[1005][35];
int main()
{
int i,j,k;
double p1,p2;
while(scanf("%d%d%d",&m,&t,&n),m,t,n)
{
memset(dp,0,sizeof(dp));
memset(s,0,sizeof(s));
for(i=1;i<=t;i++)
for(j=1;j<=m;j++)
scanf("%lf",&p[i][j]);
for(i=1;i<=t;i++)
{
dp[i][0][0]=1.0;
for(j=1;j<=m;j++)
dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);
for(j=1;j<=m;j++)
for(k=1;k<=j;k++)
dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
s[i][0]=dp[i][m][0];
for(k=1;k<=m;k++)
s[i][k]=s[i][k-1]+dp[i][m][k];
}
p1=p2=1.0;
for(i=1;i<=t;i++)
p1*=(s[i][m]-s[i][0]);
for(i=1;i<=t;i++)
p2*=(s[i][n-1]-s[i][0]);
printf("%.3f\n",p1-p2);
}
return 0;
}