HUST 1010 The Minimum Length

                    F - The Minimum Length

Time Limit:1000MS Memory Limit:131072KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

HUST 1010
Description
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA…… Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A=”abcdefg”. I got abcd efgabcdefgabcdefgabcdefg…. Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input
Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.
Output
For each line, output an integer, as described above.

Sample Input
bcabcab
efgabcdefgabcde

Sample Output
3
7

仔细想一下Kmp 中 next[]数组的意义就好了!!!!

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#define N 1000005
using namespace std;
int nexts[N];
char s[N];

void get_nexts(char s[],int nexts[])
{
    int i=0,k=-1,len=strlen(s);
    nexts[0]=-1;
    while(i<len)
    {
        if(k==-1||s[i]==s[k])
        {
            i++,k++;
            if(s[i]==s[k])
                nexts[i]=nexts[k];
            else nexts[i]=k;
        }
        else k=nexts[k];
    }
}
int main()
{

    while(~scanf("%s",s))
    {
        //printf("*******\n");
        get_nexts(s,nexts);
        //printf("*******\n");
        int len=strlen(s);
        printf("%d\n",len-nexts[len]);
    }
    return 0;
}

你可能感兴趣的:(HUST 1010 The Minimum Length)