题目二:ZOJ问题
题目三:奥运排序问题
题目四:最短路径问题
/************************************************************************/
/* 最短路径问题
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2114 Accepted Submission(s): 659
Problem Description
给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。
Input
输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。
(1<n<=1000, 0<m<100000, s != t)
Output
输出 一行有两个数, 最短距离及其花费。
Sample Input
3 2
1 2 5 6
2 3 4 5
1 3
0 0
Sample Output
9 11
Source
浙大计算机研究生复试上机考试-2010年
*/
/************************************************************************/
//这个是SPFA法,Dijkstra法见下个代码
#include"iostream"
#include"queue"
#include"vector"
using namespace std;
#define N 1005
#define INF 100000000
int n,m;
struct MAP
{
int node;
int dis;
int cost;
MAP(int a,int d,int p)
{
node=a,dis=d,cost=p;
}
};
vector<MAP>map[N];//map[i][j]表与节点i相连的第j条边的信息
int minres[N][2];//min_dis/cost from s to i
void spfa(int s,int e)
{
queue<int>Q;
bool used[N]={false};
Q.push(s);
used[s]=true;
int i;
for(i=1;i<=n;i++)
minres[i][0]=minres[i][1]=INF;
minres[s][0]=minres[s][1]=0;
while(!Q.empty())
{
int now=Q.front();
Q.pop();
used[now]=false;//
for(i=0;i<map[now].size();i++)
{
int tmpend=map[now][i].node;
int dis=map[now][i].dis;
int cost=map[now][i].cost;
if(minres[tmpend][0]>minres[now][0]+dis||
(minres[tmpend][0]==minres[now][0]+dis&&
minres[tmpend][1]>minres[now][1]+cost))
{
minres[tmpend][0]=minres[now][0]+dis;
minres[tmpend][1]=minres[now][1]+cost;
if(!used[tmpend])
Q.push(tmpend);
used[tmpend]=true;
}
}
}
}
int main()
{
while(scanf("%d %d",&n,&m)!=EOF&&!(m==0&&n==0))
{
int a,b,d,p,i,j;
for (i=1;i<=n;i++)
map[i].clear();
while (m--)
{
scanf("%d%d%d%d",&a,&b,&d,&p);
map[a].push_back(MAP(b,d,p));//注意双向边
map[b].push_back(MAP(a,d,p));
}
scanf("%d%d",&a,&b);
spfa(a,b);
printf("%d %d\n",minres[b][0],minres[b][1]);
}
}
法二 Dijkstra
#include"iostream"
#include"vector"
using namespace std;
#define N 1005
#define INF 1000000000
int n,m;
struct Map
{
int point;//another point of edges connect this point
int dis;
int cost;
Map(int x,int y,int z):point(x),dis(y),cost(z){}
};
vector<Map>map[N];
int minres[N][2];
void bfs(int s,int e)
{
int i,j;
for(i=1;i<=n;i++)
minres[i][0]=minres[i][1]=INF;
minres[s][0]=minres[s][1]=0;
bool used[N]={false};//false--in the end point set
for(j=0;j<n;j++)//n loops
{
int mindis,mincost,tmp;
mindis=mincost=INF;
for(i=1;i<=n;i++)//find a point with min dis and min cost
{
if(!used[i]&&(minres[i][0]<mindis||minres[i][0]==mindis&&minres[i][1]<mincost))
{
mindis=minres[i][0];
mincost=minres[i][1];
tmp=i;
}
}
int p1,d1,c1;
//update paths connect to point tmp
for (i=0;i<map[tmp].size();i++)
{
p1=map[tmp][i].point;
d1=map[tmp][i].dis;
c1=map[tmp][i].cost;
if((minres[p1][0]>minres[tmp][0]+d1||
minres[p1][0]==minres[tmp][0]+d1&&minres[p1][1]>minres[tmp][1]+c1)&&
!used[p1])
{
minres[p1][0]=minres[tmp][0]+d1;
minres[p1][1]=minres[tmp][1]+c1;
}
}
used[tmp]=true;
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF&&!(m==0&&n==0))
{
int a,b,d,p;
for (int i=1;i<=n;i++)
map[i].clear();///////////千万注意!
while(m--)
{
scanf("%d%d%d%d",&a,&b,&d,&p);
map[a].push_back(Map(b,d,p));
map[b].push_back(Map(a,d,p));
}
scanf("%d%d",&a,&b);
bfs(a,b);
printf("%d %d\n",minres[b][0],minres[b][1]);
}
}
。。。
/************************************************************************/
/*
@Function: Min Path
@Method: Dijikstra+Priority_Queue
@Author: zrq sophia
*/
/************************************************************************/
#include"iostream"
#include"vector"
#include "queue"
using namespace std;
#define N 1005
#define INF 1000000000
int n,m;
struct Map
{
int point;//another point of edges connect this point
int dis;
int cost;
Map(int x,int y,int z):point(x),dis(y),cost(z){}
};
vector<Map>map[N];
int minres[N][2];
struct WAY
{
int dis;
int cost;
int point;
bool operator < (const WAY a)const
{
if(a.dis==dis)
return a.cost<cost;//sort from small to big
return a.dis<dis;
}
};
void bfs(int s,int e)
{
int i,j;
for(i=1;i<=n;i++)
minres[i][0]=minres[i][1]=INF;
minres[s][0]=minres[s][1]=0;
priority_queue<WAY>Q;
WAY now,temp;
now.point=s;
now.dis=now.cost=0;
Q.push(now);
bool used[N]={false};//false--in the end point set
int tmp;
while(!Q.empty())
{
now=Q.top();
Q.pop();//use priority queue to ensure pop the point with min minres[][]
tmp=now.point;
int p1,d1,c1;
//update paths connect to point tmp
for (i=0;i<map[tmp].size();i++)
{
p1=map[tmp][i].point;
d1=map[tmp][i].dis;
c1=map[tmp][i].cost;
if((minres[p1][0]>minres[tmp][0]+d1||
minres[p1][0]==minres[tmp][0]+d1&&minres[p1][1]>minres[tmp][1]+c1)&&
!used[p1])
{
minres[p1][0]=minres[tmp][0]+d1;
minres[p1][1]=minres[tmp][1]+c1;
now.point=p1;
now.dis=minres[p1][0];
now.cost=minres[p1][1];
Q.push(now);
}
}
}
used[tmp]=true;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF&&!(m==0&&n==0))
{
int a,b,d,p;
for (int i=1;i<=n;i++)
map[i].clear();///////////千万注意!
while(m--)
{
scanf("%d%d%d%d",&a,&b,&d,&p);
map[a].push_back(Map(b,d,p));
map[b].push_back(Map(a,d,p));
}
scanf("%d%d",&a,&b);
bfs(a,b);
printf("%d %d\n",minres[b][0],minres[b][1]);
}
}
题目五:二叉搜索树
/************************************************************************/
/*3791 二叉搜索树
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 556 Accepted Submission(s): 242
Problem Description
判断两序列是否为同一二叉搜索树序列
Input
开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉搜索树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉搜索树。
Output
如果序列相同则输出YES,否则输出NO
Sample Input
2
567432
543267
576342
0
Sample Output
YES
NO
Source
浙大计算机研究生复试上机考试-2010年
*/
/************************************************************************/
#include "iostream"
#include "string"
using namespace std;
string pro;
string origin;
struct Tree
{
char name;
Tree* l;
Tree* r;
Tree()
{
l=r=NULL;
}
};
bool equal(Tree *a,Tree *b)
{
if(a==NULL&&b==NULL)
return true;
else if(a==NULL&&b!=NULL||a!=NULL&&b==NULL)
return false;
if (a->name==b->name)
return equal(a->l,b->l)&&equal(a->r,b->r);
return false;
}
void insert(Tree** root,char c)
{
if (*root==NULL)
{
*root=new Tree;
(*root)->name=c;
}
else
{
if (c<(*root)->name)
insert(&(*root)->l,c);
else
insert(&(*root)->r,c);
}
}
int main()
{
int n,in;
while (scanf("%d",&n)!=EOF&&n!=0)
{
cin>>origin;
Tree *t1=NULL;
for(in=0;in<origin.length();in++)
insert(&t1,origin[in]);
for (int i=0;i<n;i++)
{
cin>>pro;
Tree *t2=NULL;
for(in=0;in<pro.length();in++)
insert(&t2,pro[in]);
if(equal(t1,t2))
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
}
}